Atma Xplorer

Xploring Games, Computing, Photography

LightVSH Menu v7 for 6.35 Hen and 6.31 Hen

PSP Homebrew developer has updated his LightVSH menu plugin with a few bugfixes and additional features.  If you’re on 6.35 Hen or 6.31 Hen, you’ll want to update to LightVSH Menu v7. Requirements:A PSP with


Games compatible with OpenIdea ISO loader

This is a compatibility list for PSP users using OpenIdea ISO loader. If you’re on the following firmwares 6.20 TN-A Hen, 6.20 TN-B Hen, 6.20 TN-C Hen then be sure to check out this


HowTo: Downgrade your PSP from 6.35/6.31 to 6.20

Davee (yep, the very same guy that the PSP community owes the ChickHen Hack to) has released a downgrader that will allow PSPs currently on 6.31 & 6.35 to downgrade their firmwares to 6.20.


Install Signed 6.31 Hen PRO + Prometheus ISO loader on your PSP

Oh look, 6.31 Hen now also has a signed installer allowing you to install 6.31 Hen without running the Minna no Sukkuri demo exploit as instructed in the original post. With Liquidzigong’s release


Install 6.31 Hen + Prometheus ISO loader on your PSP

PSP owners with 6.31 OFW can now have cfw installed courtesy of the 6.31 Hen, 6.31 hbl by wololo and the Prometheus ISO loader.  Note that if you’re on 6.20 OFW, follow this guide


website stats