Atma Xplorer

Xploring Games, Computing, Photography

Install Signed 6.35 Hen PRO + Prometheus ISO loader on your PSP

Great news for PSP users running 6.35, you can now install 6.35 Hen without running the Minna no Sukkuri demo exploit as instructed in the original post.  With Liquidzigong’s release of a signed 6.35 PRO, you can run it directly from your XMB.

Requirements for Signed 6.35 Hen PRO and Prometheus ISO loader

  • A PSP-3000, PSP-2000 with TA-v88v3 motherboard or PSP Go with official firmware 6.35 installed. If you have a hackable PSP, I would recommend to install a permanent CFW like 5.50 GEN-D3.  If you’re not on 6.35, follow the upgrade guide for your PlayStation Portable on the troubleshooting part of the guide
  • Signed 6.35 Hen v3 (note that version 3 is the latest version.  Version 2 is here for here archive purposes only)
  • Light VSH menu: PSP-2000 | PSP-3000 | PSP Go
  • Prometheus ISO loader


Important Note: If you’re installing on a PSP-2000, be sure to turn off the UMD cache otherwise the Hen may not run

Installing Signed 6.35 Hen PRO and Prometheus ISO loader on your PSP

  • Extract the Light VSH menu file for your PSP model on your computer.
  • Copy the plugins folder directly onto your memory stick or the storage of your PSP Go.
  • Extract the Signed 6.35 hen.zip file onto your PC
  • Copy the extracted folder to x:\PSP\GAME (x is your memory stick or the PSP Go‘s storage)
  • Extract the Prometheus ISO loader onto your PC
  • Copy the extracted folder to x:\PSP\GAME (x is your memory stick or the PSP Go‘s storage)
  • On your XMB, the 6.35 Hen installer and follow the onscreen prompts
  • Once you’re back on the XMB, press “select” to make sure the Hen menu displays correctly.
  • Follow this guide: Installing the Prometheus ISO loader on your PSP.
  • Enjoy your Free PSP Games :).

Update: Added installation of Light VSH Menu.  Why is it at the start of the installation process?  So you can immediately load it after installing the Signed 6.35 Hen.

Important Note: Be sure to check the Prometheus ISO loader compatibility guide
Important Note: You need an ISO folder in your PSP’s memory. Simply create one and dump your PSP ISOs/CSOs there.

A bit of warning, this Signed 6.35 Hen PRO does not include HBL (Homebrew Loader) so you may not be able to run plugins as some of them require kernel access.  Still if you’re just looking to load ISOs on your PSP then this is as simple as it gets.  If you still want to run homebrew applications however, I’d recommend the 6.35 Hen over this.

Troubleshooting:

If you’re not on 6.35 OFW, follow this guide on how to upgrade your PSP to 6.35 so you can install Signed 6.35 Hen: HowTo: Upgrade your PSP to 6.35 OFW.

Source: Liquidzigong’s Twitter, Wololo

If you’re on a different firmware, you may want to take a look at other Hen installations:

Tags: , , , , , , , ,

Comments ( 137 )

Have Something To Say ?

  1. reeve24 January 19, 2011 Reply

    Thanks man!! it’s working! i’ve PSP 2000..
    but why should i load Signed 6.35 Hen everytime i reboot my psp?
    and there’s something weird happened when i load Signed 6.35 Hen.. i got black screen and back to XMB.. if i press “Select” there’s no Hen menu display.. but i got 6.35 Pro on my system info..
    what’s wrong? any advice?

    • sylv3rblade January 19, 2011 Reply

      You need to reload it because it’s not permanently installed on your system.
      As for the VSH menu, probably because of your PSP model.

  2. reeve24 January 19, 2011 Reply

    not permanently installed? is that normal? do u know how to install it permanently?

    • sylv3rblade January 19, 2011 Reply

      yes it’s normal. Currently there’s no way to permanently install this on your PSP.

  3. Lee88 January 21, 2011 Reply

    thanks. it works. but when i start a game and load the save game it says save data corrupted. is it usual?

    • sylv3rblade January 21, 2011 Reply

      Are you trying to load a new game?
      Have you tried any other game?

      • Lee88 January 23, 2011 Reply

        nope. i tried to load the save game that i played before i upgrade to 6.35. any suggestions? thanks a lot

        • sylv3rblade January 23, 2011

          Ah, this is part of the risk when upgrading :/ Are all your other saves corrupted as well?

        • Lee88 January 24, 2011

          oh. i think it’s just this one.

  4. banban January 22, 2011 Reply

    hello….. is there a signed 6.31 HEN ????…

    i really need it…

    thanks

    • sylv3rblade January 22, 2011 Reply

      For now there’s none since most of the devs have jumped on to 6.35

  5. banban January 22, 2011 Reply

    syl….may you give me the download link of the OFW of 6.35…..

    i am following your advices…..

  6. banban January 22, 2011 Reply

    ok…. i’ll wait….. thank a lot bro….. just reply here… ^_^

  7. banban January 22, 2011 Reply

    it is corrupted data… awts…

    • sylv3rblade January 22, 2011 Reply

      odd, can you take a screenshot of the directory where you put the update folder?

  8. banban January 22, 2011 Reply

    hahaha…it is working now… you gave me wrong directory… X:\PSP\GAME\UPDATE

    UPGRADING NOW….

  9. banban January 22, 2011 Reply

    it is working bro… thanks a lot…

  10. watayano January 22, 2011 Reply

    I have a quick question. where do i place the downloaded iso games?

    • sylv3rblade January 22, 2011 Reply

      create an ISO (or if you already have one) and copy your games there.

  11. nadine January 22, 2011 Reply

    if i install it , no homebrew work ? like emulators? picodriver?

    • sylv3rblade January 22, 2011 Reply

      Homebrew yes, plugins no.

      • nadine January 22, 2011 Reply

        so the iso loader , picodriver , and n64 will work on this ?

        • sylv3rblade January 22, 2011

          Yep. It’s basically the same as the 6.35 Hen, just without the ability to run the plugins and is much easier to install on your PSP (since you don’t need to run Minna no Sukkuri)

        • nadine January 22, 2011

          nice, is it compatible with all iso ? and if i turn off my psp will it go off?

        • nadine January 22, 2011

          hey i have 6.31 pro on my psp how can i install it ? do i need the ofw 6.35 first ? from where i get it ?

        • nadine January 22, 2011

          i also need to ask you something if i use the other one , but no signed , will cxmb work for me ? with any ctf theme?

  12. banban January 23, 2011 Reply

    @nadine…. sylverblade gave me this link…. upgrade your psp to 6.35…..

    extrace the zip file and copy the file “eboot.pbp” to X:\PSP\GAME\UPDATE

    http://uploading.com/files/7bd2d16b/PSP_6.35_FW_UPDATE.zip/

    after upgrading it… follow the steps above….

    • nadine January 23, 2011 Reply

      help it says that the firmware isnt compatible it cannot be started i must use update data that is compatible with the model in use visit sony website for your region i cant start the update help me pleasee

      • sylv3rblade January 23, 2011 Reply

        Odd.. I’ll do a recheck on the file and see if I need to upload a different updater.

        • nadine January 23, 2011

          i have a psp go , maybe your update isnt compatible ? i tried also 2 different updates and have the same problems , maybe my psp need update from different region , ? its arabian?

        • sylv3rblade January 23, 2011

          Nah, it’s the updater. Banban’s PSP isn’t a Go which is why it worked. Currently uploading a 6.35 updater for the PSP Go. :)

        • nadine January 23, 2011

          okay thanks im waiting

        • nadine January 23, 2011

          is it safe to use this on this firmware :

          http://forums.daedalusx64.com/viewtopic.php?f=12&t=2640

        • sylv3rblade January 23, 2011

          Yep it’s safe but I’m not sure if it’ll work :/ compatibility issues.

        • nadine January 23, 2011

          okay thanks now this updates works now im charging my psp then ill use this firmware , if i use the normal firmware can i use cxmb plugin ? for ctf themes ? (themes rather than the 3rd birthday) i have my own made one when i had my psp 1000

        • nadine January 23, 2011

          it works thanks…

        • sylv3rblade January 23, 2011

          Try this:
          http://uploading.com/files/fc225de7/PSP_6.35_GO_FW_UPDATE.zip/

          Put the folder inside in PSP\GAME\Update

        • nadine January 23, 2011

          thanks ill try it now , damn my download speed is 15kb/s

        • nadine January 23, 2011

          thanks this update works now im charging my psp when ill start with this firmware

  13. banban January 24, 2011 Reply

    @nadine & syl

    sorry my bad…. i really dont know what psp you have… hahahahah

  14. sylv3rblade January 24, 2011 Reply

    updated the new link to Signed 6.35 Hen Pro version 3.

    You guys may want to upgrade to this build (just rerun everything) if you’re experiencing problems when installing plugins.

  15. WOONCH January 25, 2011 Reply

    I still using 5.03 Prometheus-4 on my PSP 3006, I’m just not ready to update to 6.35 Hen PRO.

  16. Robin January 25, 2011 Reply

    It works! But Monster Hunter Portable 3rd won’t load, it just goes black when I load it via Prometheus IsoLoader. What can I do, please assist me if you can via here, or mail. I would appriciate this incredibly much.

    Kind Regards

    • sylv3rblade January 25, 2011 Reply

      Try looking for an untouched/unpatched MHP3G ISO.

      • Robin January 25, 2011 Reply

        @sylv3rblade: Pretty sure mine is, but guess I’ll keep looking if it’s working for anybody else, please contact me via mail.

        • sylv3rblade January 25, 2011

          Looks like MHP3G isn’t working even with the Openidea ISO loader.

        • teprak February 13, 2011

          For those getting the black screen problem when loading MHP3, it’s because you’re missing a file in your prometheus folder called “isofs_550.prx”.
          Find and download it with google and MHP3 will work then.

          You can also use 6.35 Pro-A to sidestep this problem too, I think, but Pro-A currently has a bug that breaks any PSN content you have.
          If you don’t care for PSN, use Pro-A.

  17. Robin January 25, 2011 Reply

    Yeah, definately not the iso I’d say, tried 3 different versions now. It just goes to black and then doesn’t move, mhfu starts up fine. Help :(

  18. Kyu January 26, 2011 Reply

    Yeah, I can’t get any kind of .cso or .iso file to work using Prometheus after I start up the 6.35 Signed Hen, it just black screens like a bitch after I try to load the .iso.

    Also, anyone know a psx emulator I could run on the 6.35 Signed Hen? I’m pretty new to HEN, I tried it awhile back with my 1000, but it never worked, so I’ve just updated as I’ve went along and now I’m at 6.35.

    I’m working on getting the 5.00 OFW so I can flash back to that with Hellcat’s, then install the 5.50 FW so I can get 5.50 Gen-D or whatever on here, since I’ve got a 1000 and stuff.

    Dial-Up is a dick….

    • sylv3rblade January 26, 2011 Reply

      Some folks have confirmed that the Popsloader for 5.50 GEN-D3 works for 6.35 Hen (both the signed and non-signed versions). Also if you’re looking to downgrade, you may want to wait for the new Hellcat’s Recovery build. As of now, build 1.65 works with 6.20 TN Hen.

  19. banban January 26, 2011 Reply

    i have psp 2000 with OFW 5.50 how to hack this thing syl ???

  20. banban January 26, 2011 Reply

    dude, which is best to use 6.20 TN-C or 6.35 PRO ??????

    i am confused right now…..

    • sylv3rblade January 26, 2011 Reply

      both are currently in development but 6.20 is getting updates faster.

  21. aamp96 January 27, 2011 Reply

    how to take screenshots or do other things with this VSH Menu…

  22. Jawwad Ali February 3, 2011 Reply

    do smackdown vs raw 2011 run on psp 3004 6.35PRO

  23. enrique vasquez February 5, 2011 Reply

    how do i work the vsh menu

    • sylv3rblade February 6, 2011 Reply

      press select. Do note that by default, if you don’t have the light VSH plugin installed (which is included in this guide), you don’t have a VSH menu

  24. DEATH2COME February 8, 2011 Reply

    Thanks, the HEN and Prometheus works great. I have one question though. I transfered savedata from one stick to another and reinstalled HEN and whatnot. Before the switch, I had no problems with the ISO, same with my sisters. But now the game that uses the savedata freezes at a certain part of the game for me. I’ve read that it might have something to do with plugins being there from before I switched sticks. If it is the plugins, is there a way to disable them? Or is there another problem?

    • sylv3rblade February 8, 2011 Reply

      I’m thinking the stick you’re using now is suspect because if there was a problem with the plugins, saves, etc, it simply wouldn’t run. Try backing things up, reformat the memory stick and then recopy your files.

      Also, you said you have reinstalled Hen, are you using the very same Hen version as before?

      • DEATH2COME February 8, 2011 Reply

        I reformatted the stick and put everything back on, but the ISO keeps freezing at that exact point, or area. I’ve reformatted and reinstalled a few times, and I got past the freezing point once, but the game ended up freezing shortly afterwards.

        As For the version of Hen, it’s the same file I downloaded from here.

        I have a feeling the problem deals with my stick switching since it works perfectly fine with my sister’s PSPs. But I don’t know for sure.

        • DEATH2COME February 8, 2011

          Also, I just noticed that my system version went from just “6.35″ to “6.35 PRO” if that matters. I don’t know how.

        • sylv3rblade February 8, 2011

          It could that the memory stick has some damage which is why you’re having problems (e.g. game freezing). But then again it could also be a problem with the card reader on your PSP.

          I would suggest using a different stick, reformat, recopy files then trying it again to see if the problem persists. If it does, you may need to have your PSP checked.

          As for the 6.35 Pro, don’t worry, it just indicates that your PSP has cfw installed.

        • DEATH2COME February 8, 2011

          Hm, I tried using a stick with the same things installed on it as mine and it works perfectly fine. I guess it’s my stick, O.o

        • sylv3rblade February 8, 2011

          oh. I had it the other way around ._. my bad.
          Yeah, try a different stick.

  25. sylv3rblade February 8, 2011 Reply

    Great news for 6.35 users, 6.35 Pro-A has been released: http://www.atmaxplorer.com/2011/02/install-6-35-pro-a-on-your-psp/

  26. Manesh February 13, 2011 Reply

    A part of Light VSH menu, everything is working on PSPgo N1003.

    When I press Help nthg happens, but can play iso games. Tested MH3p

    Thanks :)

  27. Hesoca February 26, 2011 Reply

    Thanks alot ihve installed this dumber but i have a question
    if i edit my PSP with this loader can i connect to the net without blocking my PSP?

    • sylv3rblade February 26, 2011 Reply

      Yes, you can still connect to PSN via your PSP with 6.35 Hen

  28. andreas February 27, 2011 Reply

    hi i have a problem too..
    once i had the psp power off and i removed the card..now when i go to the prometheus iso loader it says “the game cannot be started the data is corrupted”..
    any help????

    • sylv3rblade February 27, 2011 Reply

      Just re-run 6.35 Hen again before running Prometheus ISO loader

      • andreas February 27, 2011 Reply

        i have done it five times but nothing..
        any other solution??
        thanks anyway

        • sylv3rblade February 27, 2011

          Hmm.. that is odd, have you tried redownloading and the replacing your current files for the installer?

        • andreas February 27, 2011

          no i ll try..thanks a lot..!

  29. Whz*Mhiztah018 March 9, 2011 Reply

    Is it working on 6.31 OFW ??

    • sylv3rblade March 9, 2011 Reply

      You need to update to 6.35 ofw or use Signed 6.31 Hen

  30. wilson March 30, 2011 Reply

    where do i create the ISO folder

    • sylv3rblade March 30, 2011 Reply

      Create it on the root directory of your memory stick

  31. che April 2, 2011 Reply

    when i run ranchet and clank size matters cso my psp cuts off

  32. che April 2, 2011 Reply

    but every thing else like the menu works but games shut down when i run it on the iso loader

  33. che April 2, 2011 Reply

    nope i cant play no games it just restarts

  34. thea April 8, 2011 Reply

    hi. question? i have psp 3k chicken hack wid prome 3. can i upgrade to above version? how can i do that? thanks

    • sylv3rblade April 8, 2011 Reply

      Yep. Just unload chickhen and update to 6.35 then follow the instructions above.

  35. ecchijosh April 13, 2011 Reply

    Yo… here’s the question.. Is there anyway for me to downgrade my psp – 2000 OFW 6.35 to 5.50 GEN-D without using a pandora battery or a magic mem stick??

    • sylv3rblade April 13, 2011 Reply

      If your PSP is hackable then yes, there is a way but if it’s not then that’s a negative.

      • Elias May 11, 2011 Reply

        Hi, I’ve been reading pretty much everything you’ve posted so far but I’m still having trouble getting this thing to work. Here’s what I’ve done.

        I have 3004 PSPslim with 6.35proB5 CFW installed aswell as the Prometheus ISO loader. I have a confirmed working CSO file (Persona 3. ) from that site you referred to and I have placed that file in an ISO folder in my memory Root.

        When I start up Prometheus I can change the ISO mode, refresh and exit. I can’t change the directory, or at least, it’s not responding.

        Where could I have gone wrong and could you please help me with this?

        Thanks in advance – Elias

        • sylv3rblade May 11, 2011

          Hi Elias, with 6.35 Pro-B5, you don’t really need the Prometheus ISO loader since it has better drivers (inferno)

        • Elias May 12, 2011

          I don’t?

          Haha, guess I got a bit confused reading posts made almost 2 years ago. So do I just place the .CSO files in my ISO folder and it should pop up? Or do I need to configure anything before? I am really sorry for troubling you but considering how hard of a time I’ve had finding up to date information it would be of much help and very appreciated if you could point me in the right direction.

        • sylv3rblade May 12, 2011

          Yep. Just pop them in that folder and they should come up as playable straight from the XMB

        • Elias May 12, 2011

          Hah, Thanks alot seems like I was doing it right from the beginning only that I was using a file that didn’t seem to work.

  36. Dotty May 25, 2011 Reply

    I have a PSP 2006. I am using chicken R2 on 5.03 firmware for now. each time i switch off I have to use the egg tiff exploit, then CFWenabler xenogears & Becus25. Can I use signed 6.5 hen pro? I only play ISO

    • sylv3rblade May 25, 2011 Reply

      Upgrade to 6.35 Pro-B5 instead.

      Do note.. fully turn off your PSP before proceeding to unload ChickHen

  37. Dotty May 26, 2011 Reply

    How about PSP GO , Firmware 6.5??

    • sylv3rblade May 26, 2011 Reply

      You can use 6.35 Pro-B5 on the PSP Go as well.

      • Dotty May 26, 2011 Reply

        ok its in my psp go. works great so far. It cant be installed permanently right. I tried switch of completely and then back on it was gone. I used fast recovery now its ok. Do I need to keep the PROUPDATE folder on PSP??

        • sylv3rblade May 26, 2011

          You can remove the Pro update folder but I would advise to keep it just in case. :)

        • Dotty May 28, 2011

          Ok thx. Done on my psp 2006 too works great. two last questions hopefully :D.
          1. did you advice me to use 6.35 Pro-B5 because its the latest or is it the one i should use for PSP GO and psp 2006??
          2. I got some purchased games from psp GO. I copied the folder + eboot.pbp to my psp 2006 and i get error 80010087 game cannot be started. is there a way to get this to work??

        • sylv3rblade May 28, 2011

          1. I would advice 6.35 Pro-B5, it works great on the Go.
          2. What game are you trying to play? Did you copy the games manually to your PSP? Have you tried to login to the PSN (basically activate your PSN account on your PSP) from the PSP -> this is required to play any purchased PSN content?

        • Dotty May 29, 2011

          2. Ben 10 vilgax attack os the game. I just copied it from my friends PSP Go to my psp 2006. I do not have a PSN account. There isn’t any way to get the game to work apart from PSN account ???

        • sylv3rblade May 29, 2011

          Nope. You really need to activate your PSP via PSN.

        • Dotty May 29, 2011

          Tried to activate thru PSN network on the cfw i get connection timed out. when use the OFW i’m asked to do a required update before proceed. any advice? i know i should not update firmware tho

        • sylv3rblade May 29, 2011

          Install to 6.35 Pro-B5

        • sylv3rblade May 29, 2011

          Also, PSN is down at the moment for some regions it seems :/

        • Dotty May 29, 2011

          ok. done installing 6.35 pro-B5 since before. when i tried PSN with it i get connection time out. But if i switch off completly (going back to OFW) i am asked to do a required update before proceed. Ill wait and see if the connection timeout error fixes itself

  38. Quietus June 8, 2011 Reply

    Hi Sylverblade
    I’m running a PSP 2001 with 6.35pro b6. I’m trying to run a patched version of MH3rd. On the XMB the MH3rd ISO shows up as corrupted, but on the Prometheus loader it shows up as a valid ISO. However, when I load it, I get a black screen and have to hit the Home button to get back to the dashboard. Do you have any suggestions for me so I can get MH3rd running? Thanks very much.

    • sylv3rblade June 8, 2011 Reply

      Patched as in patched with the english translation or patched for a different firmware? The ISO could be both which is why it’s not loading properly.

  39. Sumstah June 12, 2011 Reply

    I have installed 6.35 HEN and Promethus ISO Loader but i get a black screen when i click ‘x’ to load an iso. Please help thanks.

  40. sayaka June 20, 2011 Reply

    im having problems with launching my game in promethus it was working when i first tried it and then afterwards when i try to run an iso it hangs what should i do?????

    PSP-2000 signed 6.35

  41. sayaka June 20, 2011 Reply

    another thing my psp shows a message saying “the disk could not be read” do you think that is the reason why it hangs whenever i load iso games but in the psp the icon of the memory card still shows….

  42. mark June 27, 2011 Reply

    im pretty new to this one, i wanted to play kamen rider climax so bad so i might wnna try usng this firmware without sukirri. i have a psp go promotheus 0.1 then a sukirri. whenever i starts the game it hangs and doesnt continue at all.

  43. Travis Freedem July 11, 2011 Reply

    Thanks a lot. I’ve been trying forever to get isos and I finally got it.

  44. devilprince July 17, 2011 Reply

    i just got my new psp 3003 pb with version 6.35 and i don’t know how to modify it plz help…..

  45. mario July 19, 2011 Reply

    i have 6.35 POR B5 And i try run MHP3rd and she says Game could not be started (806524). I changed all drivers bt stil same ploblem and i have module 09g btw. Please help :)

    • sylv3rblade July 19, 2011 Reply

      You probably have a patched copy of the game. Download a copy from our Free PSP Game depository

      • mario July 19, 2011 Reply

        Thx :)) Now i should download all parts after extract right?

        • mario July 19, 2011

          Please tell u u got a link wyth a MHP3rd Torrent works for 6.35 pro b5 :)) thx

        • sylv3rblade July 19, 2011

          No torrents, just direct downloads

        • sylv3rblade July 19, 2011

          Yep

        • mario July 19, 2011

          ok thx now i must wait 2 days till all is downloaded :))

  46. assassin November 14, 2011 Reply

    dude is the light VSH important? If it is what is it for? :O

    • sylv3rblade November 14, 2011 Reply

      The VSH menu allows you to tweak options 6.35 HEN PRO, without it you can’t change anything.

  47. vaibhav November 22, 2011 Reply

    where do i put the bin file???

  48. vaibhav November 22, 2011 Reply

    also when i select the hen file….a weird japanese/chinese game opens….what do i do???….the instructions say tht i had 2 open the hen program then the prometheus program…can u pls help?

    • sylv3rblade November 24, 2011 Reply

      Are you using the files on this page? Because one with the Japanese game is the old installation method. Please follow the instructions on this page.

  49. verrrawr January 7, 2012 Reply

    why cant i play Corpse Party on my PSP 3000 which is updated to 6.35 Pro need help. and another thing can i still play GBA and GBC games on a psp which was already updated to 6.35 Pro if yes tell me what folder should i place the emulators Thats all.

  50. verrrawr January 7, 2012 Reply

    whoops ive just answered the 1st question i asked u by myself thanks to all the links youve got updated mine to 6.35 pro b9 now the only thing i want to ask is can i still play GBA/GBC games? thats all thanks! :))

    • sylv3rblade January 7, 2012 Reply

      Yep. You’ve just updated the driver for the ISOs so homebrew will still work.

  51. rawwrr January 8, 2012 Reply

    i cant play corpse patry on my psp 3000…what should i do??

  52. chris October 2, 2013 Reply

    its says corrupted data,,

    i have psp 3004
    6.35 HEN

Leave a Reply

website stats