Atma Xplorer

Xploring Games, Computing, Photography

Prometheus-4 for 5.00 M33, 5.03 GEN-C and 5.50 GEN-D3

Before leaving the PSP scene, Prometheus developer Liquidzigong left everyone a parting gift in the form of the Prometheus-4 module which will allow you to play games that require 6.20 OFW and above and most importantly, Monster Hunter Portable 3rd.

Here’s the Prometheus-4 add-on for each of the popular CFW for the PSP:

Prometheus-4 for 5.00 M33

Requires: 5.00 M33
Download: Prometheus-4 for 5.00 M33 | Prometheus-4 for 5.00 M33

Prometheus-4 for 5.03 GEN-C

Requires: 5.03 GEN-C
Download: Prometheus-4 for 5.03 GEN-C

Prometheus-4 for 5.50 GEN-D3

Requires: 5.50 GEN-D3
Download: Prometheus-4 for 5.50 GEN-D3

Please note that you need the required firmware to be installed before getting the modules on your PSP.

To install:

  • Extract the zip archive for your custom firmware
  • copy the Prometheus folder into X:PSP/GAME/ (that’s your Memory Stick)
  • Run the installer from the XMB and then hit X to start the installer

If you’re already on the Prometheus module, simply follow the instructions above and it will overwrite the Prometheus module installed on your system.

source: pspgweber, thanks to chyzukay for the tip :)

Tags: , , , , , , ,

Comments ( 87 )

Have Something To Say ?

  1. kathy025 January 30, 2011 Reply

    Latest official release from Liquidzigong is Prome-3v2. This is from an unknown hacker. :)

  2. Jeff February 12, 2011 Reply

    is this the latest version? i have a 5.50 gen – d3 psp 1001. any suggestions? will prometheus work for me?

  3. xero February 21, 2011 Reply

    hi i’m using GEN-C (full)… is it ok if i install prometheus even its not GEN-C only???

    • sylv3rblade February 21, 2011 Reply

      Yep it’s perfectly alright to install the prometheus module with your current firmware

  4. zlord February 28, 2011 Reply

    thanks it worked perfect for me, now i can play Monster Hunter 3 ( i was on D3)

    THANKS!

  5. luso3 April 3, 2011 Reply

    Hi , I need your help. I have firmware gen-d3 with this last update from Liquidzigong (Prometheus-4 for 5.50 GEN-D3) but I still can´t use my camera PSP-450x. The problem is not with the camera because it works on another PSP…could I do something on my firmware ? any help ? thanks !

    • sylv3rblade April 3, 2011 Reply

      What is the current firmware of the PSP that the camera works on?

      • luso3 April 3, 2011 Reply

        Hi, it works on a “fat PSP” with firmware version 6.31.

        • sylv3rblade April 3, 2011

          Is your PSP model a PSP-2000 or PSP-3000?

        • luso3 April 3, 2011

          Hi ! My PSP is a PSP-2000.

        • luso3 April 6, 2011

          Hello Svlv3rblade! could I expect any solution for my problem…?

  6. William April 5, 2011 Reply

    I have 5.50 Gen D3 and I upgraded to prometheus and my games goes corrupted!

    • William April 5, 2011 Reply

      Nevermind! Because of your help my PSP is workign again

  7. SCU Iori April 8, 2011 Reply

    How come the screenshots says Prome-4 but when I apply it, it says Prome-3.

    I am using 5.03 Gen-C

    Thank you

    • sylv3rblade April 8, 2011 Reply

      Hmm that’s odd. I guess the version hasn’t been updated for the 5.03 GEN-C build.

  8. SCU Iori April 8, 2011 Reply

    I clicked on the link above:
    Download: Prometheus-3 for 5.03 GEN-C

    The link does says Prometheus-3. So is it really Prome-4?

    Thank you for the reply

  9. Forte April 9, 2011 Reply

    I’m seeing alot of updates for PSP 2000 and 3000, then how about PSP 1000? I’m currently outdated yes, I’m kinda of the scene at the moment. Help?

  10. enigma April 17, 2011 Reply

    i have updated my firmware 2 prome-3 and there seems to be a problem on the playstation network i can’t connect anymore pls. help (imy psp is a 1000 model)

  11. montow April 20, 2011 Reply

    is it normal to see a red flash when i load any real umd game? games work fine, its just that red flash before loading makes me feel uneasy.

    • sylv3rblade April 20, 2011 Reply

      The red screen simply means it’s decrypting the game so it’ll work with your PSP.

  12. rei April 22, 2011 Reply

    i can’t seem to download Prometheus-4 for 5.03 GEN-C is there any other link?

    • sylv3rblade April 22, 2011 Reply

      reuploading to a different mirror… they’ll be up in a bit

  13. v0xc April 24, 2011 Reply

    Hi, it says Prometheus 4 but the link says “Prometheus-3 for 5.50 GEN D3″…
    Is this really Prometheus 4?

    • sylv3rblade April 24, 2011 Reply

      my bad, I was updating the post by adding the second mirror and it slipped my mind. Yes, these links are for prome-4

  14. Allain April 27, 2011 Reply

    Hi sylv3rblade, i have a psp 3000. with a firmware of 5.03 then i installed the 5.03 hen. which runs at 1 click. then i was wondering if what is the best thing to do to my psp. if I upgrade to 6.xx or stick to 5.03.

    btw, how to run Prometheus-4 at 5.03 firmware? psp 3000 here.

    many thanks.

    • sylv3rblade April 27, 2011 Reply

      For prome-4, just follow the instructions above. As for whether to upgrade or not, it depends on what you want to play. 6.xx firmwares (6.35 Pro and it’s variants, currently updated to 6.35 Pro-B5) and it’s variants have a lot more flexibility and support for newer games while 5.03 GEN-C is a much more stable release. in terms of games, 6.xx firmwares have better compatibility with newer games and sometimes fail to load with older ones while 5.03 + Prome-4 work with older games, and newer ones, for now.

      Basically it’s a choice between playing older games and newer ones although a bit of warning, upgrading from 5.03 to 6.xx might corrupt some of your saves (most notably when those saves are played from patched ISOs).

  15. macky April 30, 2011 Reply

    can i use Prometheus on a PSP 2000 and 3000 with TA088v3 mobo?

    or may be use 6.xx PRO-B?

    • sylv3rblade April 30, 2011 Reply

      Only if you’re on 5.03 GEN-C. Otherwise upgrade to any of the 6.xx firmwares

  16. overhaul21 April 30, 2011 Reply

    uhmm , i have 5.50 Gen D3, if i will install the prome 4, would it still be possible to revert it back?

    • sylv3rblade April 30, 2011 Reply

      Yep, just reflash using the XGEN Updater

      • overhaul21 April 30, 2011 Reply

        oh okay thanks,.. and one more thing, do i need to use pandora battery to install it? or any requirement aside from the firmware? i’m just scared to brick my psp. :)

        • overhaul21 April 30, 2011

          and uhmmm, the folder says 5.50 prometheus, is it 5.50 GEN-D3 really? sorry if i ask too much questions. :)

        • sylv3rblade April 30, 2011
        • overhaul21 May 1, 2011

          okay thank you. :) my last question is, is there any other requirement to install it aside from the firmware? like pandora battery or whatsoever. :D and Patapon 3 need prometheus 4 to play it right? thanks alot. :D

  17. overhaul21 May 1, 2011 Reply

    is there any other requirement to install it aside from the firmware? like pandora battery or whatsoever.

  18. ryan May 2, 2011 Reply

    sylv3rblade bakit ung patapon 3 nag oopen naman sa 5.03 prometheus 4 kaso hangang sa loading lng di nagtutuloy sa game…eto ung link sa youtube ganito nangyayari sakin..http://www.youtube.com/watch?v=qINZsG7ezLA

  19. chenster May 3, 2011 Reply

    Hi, i have a psp 3000 with MHUspeedv3, then i installed a cfw enabler (cfwenabler 3.70 by xenogears) that has 5.00m33-6.20m33 not m33-6 w.e. i was wondering if it could work. If it wont, is there like another CFW enabler or something i could try?

    Excuse my noobiness, havent played psp for a while and i wanna play patapon 3

    • sylv3rblade May 3, 2011 Reply

      Err.. You lost me at CFWEnabler ._.
      CFWEnabler is basically equivalent to 5.03 GEN-C. If you’re asking if you can install any 6.20 TN Hen, yes, but you have to upgrade to 6.20 OFW. As for Patapon 3, it’s compatible with all 6.xx Hen releases so far.

  20. Constantine May 9, 2011 Reply

    Hi I have CFW 5.50 GEN-D3…Can you please confirm that installing Prometheus 4 will not affect anything like older games? Thx in advance

    • sylv3rblade May 9, 2011 Reply

      Yep. It won’t affect your saves. It’s just an add-on after all.

      • Constantine May 9, 2011 Reply

        Ok so I just completed the updating and everything seems fine. Good thing I kept a saves backup since some were corrupted. However Ghost Recon Predator boots but has no sound on the menu and when I press new game…it shuts down the psp. I tried two different isos. Any ideas?

        • sylv3rblade May 9, 2011

          Switch UMD modes in the XMB menu

        • Constantine May 10, 2011

          By XMB you mean the recovery menu right?

        • sylv3rblade May 10, 2011

          XMB is the main menu of your PSP (Cross Media Bar)

        • Constantine May 10, 2011

          Could you tell me exactly where the umd settings are in the XMB? They are on the settings section on the far left of the menu? Sorry for making too many questions…I’m a bit of new with the psp

        • sylv3rblade May 10, 2011

          What you’re looking for is this:

          The UMD ISO mode.

          To access that menu, press select on your XMB.

  21. trumpISachump May 14, 2011 Reply

    Wow, svlv3r you have very comprehensive site, and you seem to give great help. Thanks in advance for any help.

    I have a psp2k (TA-85v2) 5.00 m33-6 and I just installed Prometheus 4 (although, while it was installing it said Prometheus-3). So I figured no big deal. I’ll still be able to run the iso and cso that I’m playing atm b/c they aren’t the newest (star ocean and Valkyrie profile lenneth) and they were playing prefect before that I applied the patch and it wouldn’t hurt. Turns out now that they don’t launch (no disc inserted err), but my emus still launch as does irshell. So I changed the iso modes but none of them work, not even the OE noUMD, or sony noUMD. What gives? If I update to 5.50 GEN D3 final, will I still be able to run the majority of home brew?

    Many thanks.

    • sylv3rblade May 14, 2011 Reply

      Yep, 5.50 GEN-D3 has pretty much the same compatibility of 5.00 M33-6 when it comes to homebrew so you can upgrade safely

  22. Saina May 14, 2011 Reply

    I am on 5.5 prometheus can i upgrade to 5.5 prometheus v4?

    • sylv3rblade May 14, 2011 Reply

      Yep, you can upgrade without any problems.

    • Saina May 15, 2011 Reply

      It work great however some of my save games are corrupted even though i backup them…rather sad

  23. trumpISachump May 14, 2011 Reply

    So I think I updated to 5.50 GEN D3 final (b/c that’s what the program that I launched said it was doing, but in system settings it says 5.50 GEN-B full), but I have the same problem as above, where i get a message when I try to launch an ISO or CSO. No matter if I change the UMD driver, I get the message about no disk inserted. I am launching from irshell 5.2. What is wrong? I want to try and launch from ISO tool but I can’t figure out how to install it (too many sub folders, making it confusing). But on the plus side my gba emu still works.

    Thanks again, for any help.

  24. trumpISachump May 14, 2011 Reply

    Yeah I did that (irshell 5.02 and patch) and I installed prom-4 for GEN-D. I can launch irshell and home brew from that. I also installed a prx into seaplugins folder called NOUMD, but I don’t remember if i added a line in the VSH text file. Is it a bug or did I fuck something up?

    • sylv3rblade May 14, 2011 Reply

      You can go to the recovery menu (restart your PSP and hold R while booting) and enable the plugin there (no need to use the VSH txt file)

  25. mathew May 19, 2011 Reply

    I have a couple of questions for you guys. Would it be better to update to Prome-4 on a PSP 3000 using CFW 5.03 GEN-C or a PSP 2000 using CFW 5.50 GEN D-3? Also, is there a version of popsloader that is compatible with a PSP 3000 updated to Prome-4 from 5.03 GEN-C? My ultimate goal is to have a PSP capable of running both PSP and PSX ISOs. Thanks a lot.

  26. Tinbox May 25, 2011 Reply

    i was trying to run Lego Pirates Of the Caribbean, it loads, screen turned red then black, froze and the psp turned off….how do i fix this? i tried switching btw sony n M33, and went to the recovery menu n switched around the 1.5 and x.xx too…..still no luck =[

  27. bUdz May 27, 2011 Reply

    I just installed Prom-4 from GEN-D3 and it corrupted some of my older save data… what have I done wrong? any way to fix this?

  28. wiltonko June 16, 2011 Reply

    hi, i’m using prom-v4 on my psp 3000 right now, n i was wondering if this is the latest version for my psp or can i use the 6.20 pro-B6 on my psp?

    • sylv3rblade June 17, 2011 Reply

      Yes, you can install 6.20 Pro-B6 but you will have to install 6.20 OFW then run the installer for 6.20 Pro-B6.

  29. aq June 21, 2011 Reply

    help.can’t install the 5.03 prome-4.the link given is prome-3…

    • sylv3rblade June 22, 2011 Reply

      Sorry about that, I’ll be updating the links in a bit

      • iyak July 4, 2011 Reply

        the link on 5.03 gen c is still prom-3 not prom-4

        • sylv3rblade July 4, 2011

          The links now point to the v4 of Prometheus

        • iyak July 5, 2011

          thanx for the update

        • iyak July 5, 2011

          is the 5.03 really prome-4 or prome-3v4?

        • sylv3rblade July 5, 2011

          Prome-4 is basically a patched Prome-3.

  30. glen June 25, 2011 Reply

    thanx it worked on my psp

  31. jim July 14, 2011 Reply

    hi sylverblade.. im using 5.03 gen-c prome 4..well the problem is when i restart it,it always turn to its original cfw 5.03..can i ask you if i can still upgrade it to 5.50 gen d3 coz i think that cfw will solve my problem..im using psp 2000 japan actually..so that i have no problems on playing monster hunter portable 3rd..ill wait for ur reply..

  32. Alexnader Poma August 4, 2011 Reply

    It happens with evry iso

    • sylv3rblade August 5, 2011 Reply

      Looks sounds like a bad flash of 5.50 GEN-D3. Download the XGen Updater on this page and run the installer again (make sure you select flash 5.50 GEN-D3 and not 5.50 OFW otherwise you’ll have to stick with non permanent CFW if you don’t have a pandora battery). After that, install the prometheus module on this page and try your ISOs again.

  33. RON August 10, 2011 Reply

    Um, I ran the installer, but when I pressed X it says cpoy file error…. install aborted. What’s the problem?

  34. John August 29, 2011 Reply

    i installed 5.50 Prometheus version on my PSP Slim. here is the link http://www.atmaxplorer.com/2010/06/install-psp-custom-firmware-5-50-prometheus/
    is that ok if im goin to install this Prometheus-4 for 5.50 GEN-D3?

  35. ken September 27, 2011 Reply

    will older games still work if I install prometheus-4? and do I need to make a backup of my psp game save data?

  36. Darkslayer November 2, 2011 Reply

    Hi,

    Same as ken’s question. Will my older psp games still work if I use Prometheus-4 add-on? And will my save files be corrupted if I use this? My psp’s current version is 5.00m33-6.

  37. buster300x December 5, 2011 Reply

    Hello…

    mine is “5.50 prometheus”. how to upgrade it to 5.5 prome V4. where is the download link for the 5.5 prometheus..

    and thank you for reply.

  38. Nick Derp April 28, 2012 Reply

    I currenty have 3.71 m33-2. Atm, i’m updating to 5.00 M33-6.

    I was planning to get 5.50 GEN-D3, to play some of the lastest games.

    Should I just go with prometheus-4 for 5.00? Will it brick my psp if i have that “M33-6″ part?

    Or update to 5.50 GEN-D3, and get prometheus-4 for 5.50 GEN-D3?

    What is the difference?

    • Nick Derp April 28, 2012 Reply

      I think I found my answer.. I need to be using ISO tool since I will be having 5.00 M33-6. Am I doing this right?

  39. Boston Brand September 16, 2012 Reply

    The download links for Gen D3 are broken (file not found).

Leave a Reply

website stats