Atma Xplorer

Xploring Games, Computing, Photography

PSP Games that block custom firmware

Sony and game publishers have started to implement a security system for PSPs that block custom firmware from within the game. They do it by checking your firmware version before booting the actual game. Currently there is no work around for this (the version.txt method doesn’t work with newer games). 5.50 GEN-B and the older 5.00 M33 simply don’t work. The only way you’ll get to play these games are to upgrade to the latest official firmware.

With this kind of DRM getting rolled out, the PSP Go is starting to look very attractive.

Here’s a list of PSP Games that block custom firmware

  • DJ Max Portable: Clazziquai Edition
  • DJ Max Portable: Black Square
  • Pangya (K)
  • Idolmaster SP (Missing Moon, Perfect Sun, and Wandering Star) (J)
  • Kidou Senshi Gundam: Senjou no Kizuna Portable (J)
  • Evangelion Jo (J)
  • Armored Core 3 Portable (J)
  • Shinseiki Evangelion: Battle Orchestra Portable (J)
  • Musou Orochi: Maou Sairin Enhanced Version (CH)
  • Tales of VS. (J)
  • G.I. Joe: The Rise of Cobra (U)

Games with specific firmware requirement:
Important Note: Most of these games will work with 5.00 M33, 5.50 MHU, 5.50 GEN-A, 5.50 GEN-B, 5.03 GEN-A and 5.03 MHU if you use the Game Decrypter.

  • Madden 2010 : requires 5.50 (solution- install 5.50 GEN-B)
  • Soul Calibur: Broken Destiny [JPN] : requires 5.55 (No work around yet)
  • Soul Calibur: Broken Destiny : requires 5.50 (download the hacked version of the game)
  • Need For Speed Shift [USA]
  • Cloudy With a Chance of Meatballs [USA] : requires 5.55 (No work around yet)
  • Dirt 2 [EUR] : requires 5.55 (No work around yet)
  • MotorStorm Arctic Edge [EUR] ‘English Only’ : requires 5.55 (No work around yet)
  • Rugby League Challenge [EUR] ‘English Only’ : requires 5.55 (No work around yet)
  • AFL Challenge [EUR] ‘English Only’ : requires 5.55 (No work around yet)
  • Disgaea 2 Dark Hero Days [USA] : requires 5.55 (No work around yet)
  • Fate Unlimited Codes [USA] : requires 5.55 (No work around yet)
  • Dissidia Final Fantasy [EUR] : requires 5.55 (No work around yet)
  • IL 2 Sturmovik Birds of Prey [EUR] : requires 5.55 (No work around yet)
  • Mawaskes [EUR] : requires 5.55 (No work around yet)
  • Samurai Dou 2 Portable [JPN] : requires 5.55 (No work around yet)
  • Simple 2500 Series Portable Vol 12 The Hohei 2 [JPN] : requires 5.55 (No work around yet)
  • Yamamura Misa Suspense Kyoto Kurama Sansou Satsuji n Jiken [JPN] : requires 5.55 (No work around yet)
  • Warriors Orochi 2 [USA] : requires 5.55 (No work around yet)
  • Soul Calibur Broken Destiny [EUR] : requires 5.55 (No work around yet)
  • Tenchu San Portable [JPN] : requires 5.55 (No work around yet)
  • Soul Calibur Broken Destiny [JPN] : requires 5.55 (No work around yet)
  • Saikyou Toudai Shougi Deluxe [JPN] : requires 5.55 (No work around yet)
  • Konjiki no Corda 2 Forte Encore [JPN] : requires 5.55 (No work around yet)
  • Ookami Kakushi [JPN] : requires 5.55 (No work around yet)
  • Dissidia Final Fantasy [USA] : requires 5.55 (No work around yet)
  • Guitarway To Heaven 5 Superstar : requires 5.55 (No work around yet)
  • Hannah Montana: Rock Out the Show [USA] : requires 5.55 (No work around yet)
  • Tales of VS [JPN] : requires 5.55 (No work around yet)
  • G I Joe The Rise of Cobra [USA] : requires 5.55 (No work around yet)
  • Armored Core 3 Portable [JPN] : requires 5.55 (No work around yet)
  • Blazing Soul Accelate [JPN]: requires 5.55 (No work around yet)

I’ll update the list once more information rolls in.

Tags: , ,

Comments ( 46 )

Have Something To Say ?

  1. dhst August 15, 2009 Reply

    There is a way to play DJ Max Portable: Black Square on CFW πŸ˜‰ For example check out this site : http://toomuchfew.info/tutorials/dj-max-portable-black-square-iso-patch

    Regards πŸ™‚

  2. Kaitlyn Young August 17, 2009 Reply

    Thanks for sharing this game news with us.I think this will be very useful for all game lovers.Sony has been my favorite brand.

  3. dhst August 17, 2009 Reply

    Spammers these days are very creative – Kaitlyn please fill me in your logic cause it’s very unlogic what you have wroted πŸ˜›

    Question to site stuff : Do you know if MediaGo checks firmware when connected to PSstore and downloading demos ?
    Since you have to connect PSP to PC when u want to DL demo.

    Thanks in advance

    • sylv3rblade August 18, 2009 Reply

      Don’t worry. They’re delinked (making their effort to comment pretty much useless)

      as for the MediaGo, can’t really say. I haven’t tried the software yet. I’m waiting to get a PSPGo before jumping to Sony’s software.

  4. dhst August 18, 2009 Reply

    On the beggining I was able to click on the link hidden behind their name πŸ˜‰ btw – they are really creative huh ? πŸ˜€

    I have checked the MediaGo and atm Ape Quest demo is downloading – no errors whatsoever. Also I DL trailer from Gamescom but haven’t played yet cause psp need to be connected to pc when u DL something from PS store ;/

    I find this site very useful – is there any way I could help ?

    • sylv3rblade August 18, 2009 Reply

      Yep. They do that all the time which is why sometimes approving comments has been a chore (some good ones end up in spam and vice versa x.x)

      Thanks for the info on the MediaGo. I’ll try it out this weekend to see if it works with CFW πŸ˜€

      As for the help, well some publicity would be very appreciated πŸ˜€ You can also send me some items you want to get posted via the Contact Me form πŸ˜€

      • dhst August 19, 2009 Reply

        What kind of publicity are you interested in ?
        Game review or more all-around-gaming article ?

        About mediago – demos will not work if u enabled some stuff in CFW. Tested Ape Quest Starter Pack on 5.50 GEN-B and after changes to one tiny setting it worked πŸ™‚
        Without change there is 80010013 error πŸ˜‰

  5. day August 29, 2009 Reply

    what happens when you try to run one of these games?
    does your psp brick? or does it just say something like “this game cannot be played. please use sony firmware”?

  6. China Guy September 1, 2009 Reply

    > what happens when you try to run one of
    > these games?

    You get an error code. Exactly the same error code as if you were running OFW that too old. What does this mean? It’s NOT a CFW related error or CFW detection. You just need newer fimware “O” or “C”. πŸ™‚

  7. Drakeon September 3, 2009 Reply

    How do i get to play Ape Quest on 5.50 GEN-B?

  8. dhst September 4, 2009 Reply

    Drakeon – go to recovery menu > then Advanced and change Game and XMB plugins to Disabled πŸ™‚

    btw Does anyone have FULL Ape Quest ? I mean both Gold and Blue since everywhere there is only Starter pack which is free to DL from PSN

  9. Edu September 12, 2009 Reply

    Ok, just to add to the list: WTF is an antiCF one. Unbound Saga instead, is firmware-specific, requiring 5.50 or higher. Hope this can be useful, as it was this list to me πŸ™‚

  10. EDU September 12, 2009 Reply

    Ok, just to add to the list:
    WTF is an antiCF one.
    Unbound Saga instead, is firmware-specific, requiring 5.50 or higher.
    Hope it will be useful, as it was this list to me πŸ™‚

  11. EDU September 12, 2009 Reply

    I beg your pardon. Wanted to correct my post and just sent the same! (My PS3 browser is not easy, sorry!)

    CORRECTION: WTF is OK. IT WORKS EITHER ON C or OF.

  12. bob September 15, 2009 Reply

    dumb question

    i have 5.00m33-6, i want to play madden 10 , if i get 5.50 GEN B do i need a pandora batery thingy or can i just install it.
    also if i do get 5.50GENb are there any disadvantages to 5.00m33-6?

    thanks in advance

    • sylv3rblade September 20, 2009 Reply

      No, you can just update to 5.50 (install 5.50 GEN-A then GEN-B).

      Several people who have commented on this blog confirmed that it’s working on 5.50 GEN-B.

  13. Valkyrie September 23, 2009 Reply

    I an using cfw 5.00 M33-6 and i can play Dissidia Final Fantasy just fine…..

    • sylv3rblade September 24, 2009 Reply

      Is that the European version? or the US version?

  14. obv September 24, 2009 Reply

    can i play the US version of persona on my 5.00 m33-6 firmware if i change the version.txt?

  15. Aiwa September 24, 2009 Reply

    Seems that the game Daxter has a check too?
    I can’t start it just like Dissidia, I get a error code 80020148.

    I even tried patching Dissidia, no luck.

  16. Modok September 27, 2009 Reply

    I just want to add that I have been able to play Final Fantasy dissidia on my CFW 5.50 MHU,(downloaded it and it worked, but I might have gotten an already patched version as it was a CSO) and I was also able to play IL 2 Sturmovik Birds of Prey [EUR] (applied a patch myself using RIPKIT), however I was unable to play Persona Shin Megami Tensei which I noticed was not on the list. It seems to be it wasnt 5.55+ firmware. I have spent all day trying to work around it, but was unsuccessful. I would really love it if someone would let me know when there is a fix for that as I have been waiting for it since it was announced.

  17. dil666 September 27, 2009 Reply

    can i change my version.txt to 5.55????…i`m using cfe 3.60 on a ta88v3…

  18. Modok September 28, 2009 Reply

    I have tried changing the version.txt (has this ever worked?) and also tried changing the /psp_game/PARAM.SFO out with one that requires a lower firmware version using UMDGEN. I read somewhere that this was a trick for making a game believe it needs a lower firmware version but this is the first time I have tried it, so who knows.

  19. Modok September 28, 2009 Reply

    I guess I forgot to conclude that thought. Neither one of these worked with Persona.

  20. @_lee September 28, 2009 Reply

    hi i just install 5.00 m33-6 and i try to play need for speed shift but in the mid of game my psp suddenly freeze ang shutdown.
    can u help me?
    my psp is psp-2006 slim

  21. dhst September 28, 2009 Reply

    I’ve played this game at 4.00 M33 πŸ˜‰ And it’s old game so probably no CFW checks in there πŸ™‚

    Just change setting like I said with Ape Escape problem (few posts above) – it should fix your issue πŸ™‚

    Regards

  22. @_lee September 29, 2009 Reply

    hi again, i tried to install cfw 5.50 gen-b n tried to play need for speed shift and SMT : Persona. for need for speed still freeze in the mid of game n persona still can’t play n there is message error can’t started the game.

    i’ve tried the setting like Ape Escape n still no luck.

    please help me, i’ve been wait to play this 2 game

  23. dhst September 29, 2009 Reply

    I’ve played NFS shift on 5.50 Gen-B and it was working correctly. Try do DL ISO not CSO. You also might clean PSP settings using recovery flash1 format πŸ™‚
    About Personas I don’t know anything.

    Soul Calibur works on 5.50 – at least CSO version πŸ˜‰

  24. Modok September 30, 2009 Reply
  25. Modok September 30, 2009 Reply

    Did not work. πŸ™

  26. Modok September 30, 2009 Reply

    Im running 5.50 MHU, does anyone know if I can go to 5.50 Gen-A or Gen-B from there?

  27. Modok September 30, 2009 Reply

    I was able to get Persona to work on 5.50 MHU using game decryptor and umdgen.

    • sylv3rblade September 30, 2009 Reply

      Thanks for the tip πŸ˜€ will add it to the post.

  28. Modok September 30, 2009 Reply
  29. Modok September 30, 2009 Reply

    But it does not mention using file->file lists-> export before decrypting the eboot.bin and using file->file list->import after adding the decrypted eboot.bin. This was the extra steps I had to take to make sure Persona worked.

  30. Modok September 30, 2009 Reply

    * For these games, you must export the file list of the original game with UMDGen (File-> File List-> Export), patch the game as explained in the tutorial, then with iso patched, forcing the list of file Designating one that you exported (File-> File List-> Import).

    This list is not complete, it will be completed as and when the test, feel free to post comments, noting the differences that you osbervΓ© in this list, not forgetting to mention your model PSP and the cfw on which you tested.

  31. Ark October 1, 2009 Reply

    Fate Unlimited Codes [USA]: Works with 5.00 M33-6 without decryption.. same goes with Dissidia Final Fantasy [USA]

    Tales of Versus[JP] Boots when decrypted but gets stuck at the black screen (can exit the game with the home button)

  32. pepso October 8, 2009 Reply

    persona does NOT work on 5.50 MHU.

    it works on 5.03 MHU, but 100 percent NOT on 5.50.

    Everybody I know used Gamedecrypter + UMDGen + EBOOT patcher with no success.

    If you, modok claim to get it working, would you please post a proof?

    Or, how did you manage to do it?

  33. Modok October 9, 2009 Reply

    Yeah I had to do the file -> export file list before decrypting and after putting the eboot.bin back into the umd I did file -> import file lists.

    http://twitpic.com/jodrp
    http://twitpic.com/jodvc

    It works. I am level 20 something right now with no lock ups or freezes or anything.

    I have a 1st generation phat psp

  34. @_lee` October 10, 2009 Reply

    thanks all
    at last my SMT persona US work with CFW 5.50 Gen-B my psp is slim

  35. Acidrocker March 27, 2010 Reply

    so will all of the games posted work on 5.03 mhu?

  36. Kitten May 2, 2010 Reply

    Fate Unlimited Codes [USA] : requires 5.55 (No work around yet) There is a “work around” With 5.50gen-D3 im able to play the game officially downloaded from the PSN network with the PSNfucker plugin.

  37. kira1000 April 8, 2012 Reply

    I know this is old but I have to speak my mind. I am really disappointed that game developers would block CFWs from using their products, I myself am a vision-impaired gamer and rely on remotejoylite (needs a cfw) in order to enjoy ANYTHING on a PSP.

Leave a Reply

website stats