Atma Xplorer

Xploring Games, Computing, Photography

LightVSH Menu v7 for 6.35 Hen and 6.31 Hen

PSP Homebrew developer has updated his LightVSH menu plugin with a few bugfixes and additional features.  If you’re on 6.35 Hen or 6.31 Hen, you’ll want to update to LightVSH Menu v7. Requirements:A PSP with


website stats