Atma Xplorer

Xploring Games, Computing, Photography

PSP 6.39 OFW now available

Just as the 6.38 to 6.20 OFW downgrader hits the PSP-centric newsrooms, Sony releases a new firmware update for the PlayStation Portable.

Important Update: You can now downgrade your PSP from 6.39 OFW or install 6.39 Pro-B6 for your LCFW needs.

This new firmware is the equivalent of the PS3’s 3.61 firmware which includes the mandatory password reset (after signing in to PSN). Of course, we can’t discount the possibility that Sony patched any of the current known exploits. After all, the changelog indicates the follow:

..system software stability during use of some features will be improve

So again, if you wish to keep your PSP compatible with the current Hen releases like 6.35 Pro-B5, 6.20 Pro-B5 or 6.20 TN-E in order to load homebrew and/or load free PSP Games, don’t update.

Tags: , ,

Comments ( 3 )

Have Something To Say ?

  1. fanoffemdom14 August 16, 2011 Reply

    hey can you actually like put a mirror for 6.39? i have 6.37 and cant use ANY cfw.

  2. fanoffemdom14 August 17, 2011 Reply

    oh my god. thanks so much ma’am!

Leave a Reply

website stats