Atma Xplorer

Xploring Games, Computing, Photography

Total_Noob’s 6.20 TN-E Hen now available

Total_N00b has just released his update to 6.20 TN Hen, 6.20 TN-E and wow, he’s thrown in everything in but the kitchen sink. PSX support, password protection, flash0 protection, improved compatibility with plugins, etc. It’s all here. And here I was thinking that 6.20 TN-E would just be a minor release.

Hats off to Total_Noob for his continuous great work. Instructions on how to install 6.20 TN-E and the download link for the installer are available after the jump.

Take a good peek at the changelog and the video below for a full list of features available in 6.20 TN-E

FULL 6.20 TN-E CHANGELOG

Added ‘TN Settings’ option to the XMB where you can adjust your configurations and plugins (based on Bubbletune’s Game Categories).
Added OSK Character Limit Increase (the Internet Browser OSK only supports 512 characters. This patch allows you to use 1518 characters).
Added password control at startup (change password in ‘Security Settings’).
Added sceUmdMan_driver patch (umd4hombrew is not necessary anymore).
Added ability to access flash0, flash1, flash2, flash3 and UMD Disc via USB.
Added PSX multi-disc support.
Added possibility to hide hen eboot in the game menu.
Added version.txt display.
Added more functions to kubridge library.
Cloned more NIDs that Sony removed in 6.20.
Fixed bug that didn’t show ‘Memory Card Utility’ in pops.
Fixed syscall execution in kernel mode (thanks to neur0n).
Redesigned NID Resolver.
Updated NID Table.
Improved plugins compatiblity: PSPConsole, Macro Fire, Custom Firmware Extender, Brightpad, Battery Warning Plugin and many more!

Translating TN Settings:

To translate the TN Settings create a text file in ms0:/seplugins/XX_tnsettings.txt / ef0:/seplugins/XX_tnsettings.txt, where XX is the language code:
ja -> Japanese
en -> English
fr -> French
es -> Spanish
de -> German
it -> Italian
nl -> Netherlands
pt -> Portuguese
ru -> Russian
ko -> Korean
ch1 -> Chinese Simplified
ch2 -> Chinese Traditional

An English text file is included. The language is English if text file doesn’t exist.

Save it in UTF-8 format if you want to use special characters.

Total_Noob also pushed a fix for a few minor bugs from the initial release

Fixed loading of game/pops plugins.
Fixed buffer overflow crash, TN Settings should work now.
Fixed bug that only allows 18 items in TN Settings.

To install 6.20 TN-E: Simply copy the PSP folder into your memory stick or internal PSPgo storage and run it from your XMB. For your ISO loader, you can go with the Prometheus ISO loader, OpenIdea ISO loader or aLoader plugin.

Download: 6.20 TN-E

Tags: , , , ,

Comments ( 35 )

Have Something To Say ?

  1. Dbrandy April 19, 2011 Reply

    Tested!!!
    Good release, thumbsup Total_Noob.
    Its awsome to have a LCFW/HEN SETTINGS included in the XMB Menu Listing..
    My system still running CFW 5.50 GEN D3, i’ll make an upgrade when the latest LCFWs are stable.

    “But still, TN is still not able to patch an ISO_Drive with his release”. Maybe we’ll welcome the likes of to have a touch on em.
    Recall: 6.20 Pro-B4, hola!

  2. Dbrandy April 19, 2011 Reply

    **Some txt was missing**
    Maybe we’ll like to welcome the likes of ‘Coldbird & Virtous Flame’ to have a touch..

    Just tryna make correction.

  3. Jibran April 30, 2011 Reply

    I’ve PSP fat 1000 can I instal in my psp fat?

    • sylv3rblade April 30, 2011 Reply

      Yes, this is compatible with all PSP models

      • janmer November 7, 2011 Reply

        sir is the TN-E Hen completely compatible to all type of PSP’s? So i just have to update my PSP firmware to 6.2 to be able to run ISO games using TN-E? Just making sure dont want to brick my console! =)

        • sylv3rblade November 8, 2011

          6.20 TN-E is compatible to all PSPs that can install 6.20 OFW (newer PSPs ship with firmware higher than this so you won’t be able to install it without downgrading). The risk of bricking is negligible since it’s not writing anything on the flash0.

        • janmer November 9, 2011

          so it doesnt really matter what type of motherboard your PSP have. Im planning to use TN-E Hen on my PSP 3000 but im not sure what its motherboard is, so ill just have to upgrade my ofw to 6.2 and install TN-E and prometeus loader and im all set?

        • sylv3rblade November 9, 2011

          As long as you are below or on 6.20 OFW, you can install 6.20 TN-E. :)

        • janmer November 9, 2011

          thanks man! ill keep in touch on updates!
          cheers!

        • janmer November 9, 2011

          thanks man ill keep in touch for updates!
          Cheers!

  4. Frank Zappatoss May 7, 2011 Reply

    Hey there sylv! Do you think it can play ff9 ripped from ps1 cd? Im currently on 6.35 b5 but I’m thinking of downgrading to 6.20 in order to play my ff9 eboot.

  5. Lusanagi May 16, 2011 Reply

    hey sylv3r, I’m trying to use MagicSave to be able to load Prologus’ save on Dissidia 012 Chinese version, but it doesn’t seem to work.
    Am I doing something wrong or is TN-E incompatible with MagicSave?

  6. mark sousa June 11, 2011 Reply

    hmm my psp keeps getting slow almost freezing

    • sylv3rblade June 11, 2011 Reply

      Check your PSP’s clock speed on the vsh menu. It could’ve been set to a slow clock speed.

      • mark sousa June 11, 2011 Reply

        oh k thnx alot hehehe!

      • mark sousa June 11, 2011 Reply

        how do i get mhp3rd using prometheus iso loader?

  7. Vin Illusion July 7, 2011 Reply

    Hi sylv3rblade , i’ve installed 6.20 TN-E and with aLoader plugin, there’s no matters with other games except for Dragonball z Shin Budokai another road / Dragonball Z shin Budokai 2.(same game only different name,file type,and source of downloaded)
    i’ve downloaded those 2 games.
    -first one is a eboot.pbp(486MB) file type (when i access to play it, popped up “the system software of your psp system version is 6.20.To start, you must update to version 6.31 or later.do you want to update now?”)
    -second one is a Shin2.cso(322MB) file type (when i access to play it,suddenly my psp has a black screen and nothing happen)

    what is wrong with it? how to solve my problem? should i upgrade my 6.20 TN-E to 6.31 OFW? then what to do after i upgrade it to 6.31 OFW?

    everytime my psp turned off,6.20 TN-E went back again to 6.20. :(

    my psp slim 2006.
    motherboard : TA-085.
    UMD firmware ver : 1.24Nov10 ,2006.
    psp ver : slim v1.0
    bat. EEPROM access : yes
    Possible CFW: Yes, w/ custom IPL.

    i used PSPident 0.74.2 to check those above.

    Please Help me sylv3rblade…

    • sylv3rblade July 7, 2011 Reply

      1.) If you upgrade to 6.31 then you won’t be able to run 6.20 TN-E or the aLoader plugin anymore. To by pass this problem, you can either download a patched version of the game you want to play or upgrade to any 6.35 LCFW (like 6.35 PRO-B6).
      2.) aLoader probably can’t run the game.

      As for the turning off bit, 6.20 TN-E is just a temporary solution. There currently is no way to install a permanent firmware on your PSP but there is a permanent patch for 6.20 TN-E that will allow it to stay on your PSP even after it turns off.

  8. Vin Illusion July 7, 2011 Reply

    thanks sylv3rblade, i will try to upgrade 6.35 PRO-B6.
    i’ve been tried to play this “dragonball z shin budokai another road” game since my CFW 5.50 GEN-D Final till 5.50 Prome-4. but all failed to can play it.. :(
    i even used isotool but failed me also…
    just hope 6.35 PRO-B6 wont fail…
    if 6.35 LCFW fail also, then i dont know what to do anymore… :(

    • Lusanagi July 7, 2011 Reply

      is your iso patched so that it sould run on 5.50? if so, maybe you need to get a clean iso

  9. Vin Illusion July 7, 2011 Reply

    Dear sylv3rblade,
    i would like to thank you many times… :D
    the 6.35 PRO-B6 completely works…
    i’ve upgraded it and satisfied with it..
    all because of you sylv3rblade…
    without you,i’ll definetly lost…..
    and also thanks to Google who make me met with this awsome Website…
    4 thumbs up for you sylv3rblade…
    oh man i’m so happy till i dont know how to thank you and your website…
    maybe i’ll treat you..?? :p
    anyway once again thank you very much sylv3rblade… :)

  10. Hope August 16, 2011 Reply

    Syl, pano kung laging pinapatay ang PSP? so lagi din iniistall ung hen, hindi ba ito nakakasira ng psp? e.g. maging unstable, or mabrick kaka Hen.

    sa pinsan ko kasing bata ito, natatakot naman akong gamitin yung Pro B baka mabrick ko.

    o mag pro B na lang ako?

    psp3004 v6.2

    • sylv3rblade August 16, 2011 Reply

      Ang risk lang ng bricking with Pro LCFW is with the permanent patch for 6.20. Otherwise it’s safe. And no, hinde nakakasira ng psp kung pinapatay mo sya lagi since (in the case of TN) wala namang sinusulat sa flash0.

      • hope August 17, 2011 Reply

        Thanks syl..

        kung sakaling mag perma patch ako worth it ba kahit may risks? or just stay sa hen/lcfw na lang ako tapos bypass na lang lagi everytime na maglalaro ako from coldboot?

        at kung sakaling mag perma patch ako TN or Pro? hindi ba nakakasira pag pinapatay lagi baka kasi laging nagooverwrite sa flash0.

        • sylv3rblade August 17, 2011

          There is always a risk when writing to flash0, hinde mawawala yun since ganun talaga ang nature ng memory na gamit sa kanya. On the upside, you get access to things like the recovery menu which will allow you to do more with your PSP. Also when you have the permanent patch (or at least any PRO LCFW installed), kapag napatay ung PSP mo, hinde mo need ireinstall since may fast recovery module naman.

        • hope September 7, 2011

          thanks syl.. sa ngaun signed TN-E ang gamit ko.. aus na din kahit galing sa coldboot since ndi nman pala katagalan pag ilalagay sa hacked mode..wala pang 5 sec.. so ndi ko lang iri-risk ung psp just to have a perm patch, less than 5 sec to be in a “hen” mode is good enough and most of all, no bricking of psp. :))

          thanks a lot syl, dami kong natutunan dito sa page mo.. more power. :)

  11. Dvp13 August 27, 2011 Reply

    okay i dnt get something. IF i turn off my psp then i have to just reload this? what’s so hard? why go for permanent?
    Is there a danger of bricking everytime i run it???

    • sylv3rblade August 27, 2011 Reply

      Yes you have to reload it everytime your PSP turns off. The reason for this is that TN Hen only remains on your PSP’s memory instead of being written into flash0. The advantage for this is that because you’re just reloading Hen, there’s no risk of bricking your PSP. There is a working permanent patch for 6.20 TN-E that will allow the HEN to stick to your PSP when you turn it off but the downside is that there’s a risk of bricking during installation.

  12. hope September 7, 2011 Reply

    syl, tanong lang ulit.. nagtataka ako, kasi madami akong nababasa na yung bookr e nara-run lang kapag naka “hen” mode pero dito sa psp ko nara-run kahit sa OFW…

    ni-run ko ung TN-E then nagbasa ako ng PDFs using bookr, then pinatay ko ang psp, chineck ko sa system info kung naka hen pa din, ang nakasulat dun e VERSION 6.20 walang TN-E.. so inisip ko asa OFW ako ulit.. then ni run ko ang iso loader, corrupted daw, pero ung bookr e nag run.. nagbabasa ako ng forums regarding dun kung possible ba talaga un pero walang result.. so iniisip ko na baka nasa “hen” mode pa rin ung psp even from cold boot.. naalala ko kasi na dati di ako maka run ng bookr nung hindi pa ako naghe-hen. ngaun nakakabasa na ako even from coldboot.

    ask ko lang sana. hehe. mejo nagulat lang din ako.. at baka mabrick ko tong psp pag lumipat ako sa ibang hen or LCFW.

    thanks syl. more power

    • sylv3rblade September 7, 2011 Reply

      Hi..

      Kaya tumatakbo yung bookr kasi “signed” application sya, meaning narerecognize sya ng PSP as an official Sony application (kahit hinde) kaya tumatakbo sya kahit OFW. Yung ISO loader naman, pwede rin na iconvert to a signed app kaso since kailangan nya ng kernel access, useless din ang pagiging signed nya kasi magagamit mo lang sya through Hen or an equivalent LCFW.

      • hope September 7, 2011 Reply

        wow.. nice.. thanks syl..dami kon natututunan sayo.. more power. :)

  13. Lozz Cozmoz November 17, 2011 Reply

    Question: Is this update a standalone update or do u need tn-a to run it?

    Thank you…

    p.s. Love the work vvv much!~ ^^b

    • sylv3rblade November 17, 2011 Reply

      You can upgrade straight to 6.20 TN-E. No need for the older releases.

Leave a Reply

website stats