Atma Xplorer

Xploring Games, Computing, Photography

6.35 Pro-B3 LCFW released

Another speedy update to 6.35 Pro LCFW, (6.35 Pro-B3) has been released with a few more bugfixes and features. From the looks of things, we’ll be seeing 6.35 Pro-C sometime soon.

Again, no need to install the previous versions. You do need to be on 6.35 OFW however. If you’re not on 6.35 OFW and want to install 6.35 Pro-B3, follow this guide: HowTo: Upgrade your PSP to 6.35 OFW.

6.35 Pro-B3 LCFW released
6.35 Pro-B3 Changelog:

[!] Fix cache bug does not generate ISO
[!] Some bug fixes recovery menu
[!] To improve the list of compatible plug-ins to support non-standard written
[+] Improved recovery menu display, plug-ins support 100 + more
[+] Add Toggle USB recovery menu
[+] Add recovery menu deception region Debug Type I / II

Download 6.35 Pro-B3:
6.35 Pro-B3 Updater
6.35 Pro-B3 Fast Recovery

or simply get

6.35 Pro-B3 Complete pack

source Virtual Flame’s blog

Tags: , , , , ,

Comments ( 25 )

Have Something To Say ?

  1. banban March 13, 2011 Reply

    alam mo ba yung 6.20 TN-D permanent patch ???

    • sylv3rblade March 13, 2011 Reply

      Yep. Pero not sure if I’ll do a post on it (although meron nang nakadraft). Risky kasi (yes it may not brick the PSP now but it still presents a risk).

  2. Gaks March 14, 2011 Reply

    Umm may psp 1000 po kasi ako medyo matagal na di na gamit version 3 something di ko po talga kasi maintindihan tong mga cfw cfw na to pero sabi sakin need pa daw ng pandora kung gusto ko yun 5.50 but diba po mas latest to? umm suggestion lng po sana pana ba po to

  3. Gaks March 14, 2011 Reply

    Umm i mean gusto ko kasi ung permanent na na firmware yung kahit mamatay yun psp ko di sya mawawala stable ano po ba recomemded nyo i dont wanna pay 800 for a downgrade

    • banban March 15, 2011 Reply

      @yow GAKS . . . . . . 5.50 GEN-D3 …. install mo yan sa psp mo…

      yan yang maganda sa mga permanent na CFW

  4. Rei Ayanami March 14, 2011 Reply

    Um, which do you think is better TN-D or PRO-B3 because I’m thinking of upgrading to B3 but I’m kind of scared of bricking? Is it worth it?

    • sylv3rblade March 14, 2011 Reply

      It really depends on what you want with your PSP. 6.20 TN-D is great if you have PSN-related games (legally bought ones) and 6.35 Pro-B3 if you don’t have them.

  5. Rei Ayanami March 14, 2011 Reply

    I see thanks. One more thing if I do upgrade to B3 is there a chance that my psp will brick during installation. I currently have a PSP-3001 with TN-D.

    • sylv3rblade March 15, 2011 Reply

      It’s relatively safe but yes, there is still a chance for a brick as you’re going to be writing on the PSP’s flash0,

  6. gaks March 15, 2011 Reply

    @ sylv3rblade, done! just followed your hellcat guide upgraded to 5.03 run chickhen r2 then hellcat then to 5.00 m33-6! yay now i im doing the promtheus update for 5.00 m33-6 but i have to ask is 5.50 gen-d3 better than m33 your opinion? cant wait to play mhp3rd

    • sylv3rblade March 15, 2011 Reply

      It really depends if you want the features of 5.50 GEN-D3.
      Also, you can play MHP3rd in both 5.00 M33-6 and 5.50 GEN-D3 by simply installing the prometheus-4 module.

  7. gaks March 16, 2011 Reply

    yeah but i cant play those really new games like Phantom Brave, Tactics orge and probobly dissidia 🙁 any solution really wanna try phantom brave

  8. banban March 16, 2011 Reply

    @gaks… i suggest…. you use 6.35 PRO-B3

  9. salzs April 3, 2011 Reply

    oh yes..i did..thank god it didn”t brick….just a question will it go if my psp restart and also can i still play originally bought umd”s no problem”s wid tht rite? my version is now 6.35-Prob3

    • sylv3rblade April 3, 2011 Reply

      You need to use the uninstall option if you want to remove 6.35 Pro-B3

  10. portal April 5, 2011 Reply

    sir i have hir a psp 2001 wid a fw of 5.03 gen c.pwde po ba ako mag upgrade sa fw n2?compatible b 2 sa ver ng psp ko?and lahat ba ng games malalaro ba sa ver 6.35?dami ko kasi games d2 and almost all of them are running with my current firmware.any advices po sir.tnx a lot.

    • sylv3rblade April 5, 2011 Reply

      Yep you can upgrade to 6.35 Pro-B3 as it is compatible with all PSP models. The catch is that if you are running games patched to run on 5.03 GEN-C, you might get some of your save games corrupted.

  11. chrisj_15 April 9, 2011 Reply

    I have 5.03 GEN-C (Full) With Prome-3. Is it worth the time to upgrade to 6.35 PRO-B3? Anyone Pls. reply, thanks.

  12. thea April 9, 2011 Reply

    hi. i tried to download 6.35 firmware in your site but it is corrupted. i have psp 3k wid 5.03 chicken prom 3. please help me how to successfully update my firmware plus to update this 6.35 pro b3. i cant play some new game eventhough i have prom 3.please help?

  13. Rogie April 19, 2011 Reply

    hi good day to all
    na update ko psp ko hindi ko kc alam na ganon
    nag update ng version 6.38 pano po ma downgrade kc hindi po ako makapag games ng iso.

    please help me

    • sylv3rblade April 19, 2011 Reply

      Unless the PSP is hackable, there’s no way to downgrade your PSP from 6.38 OFW

  14. thea April 30, 2011 Reply

    hi, i have psp 3k 5.03 prom 3 and upgraded to this version 6.35 pro. however, i noticed some of my games that i used to play in 5.03 is not working in this latest version. like the psp minis game (sky force, i must run, pacman championship etc.) how can i place these games? do i need an update of version? please help. thanks

    • sylv3rblade April 30, 2011 Reply

      upgrade to 6.35 Pro-B4 or 6.35 Pro-B5. Both of those versions use a better driver to run PSP games.

  15. thea April 30, 2011 Reply

    thank you. your the best dude!

Leave a Reply

website stats