Atma Xplorer

Xploring Games, Computing, Photography

PSP for Dummies: 6.35 OFW (and below) for non-hackable PSPs

PSP for Dummies > 6.35 OFW (and below) for non-hackable PSPs

You have reached this page because you want to install custom firmware on your non-hackable PSP but have firmware above 6.20.

While there are several HENs available (like 6.31 Hen and 6.35 Hen) for the 6.3x firmwares, I would recommend to upgrade to 6.35 OFW since most of the stable releases are targeted at that specific OFW. If you have no idea what HEN means or are lost at the terminologies, be sure to read the Terms and Definitions part of the guide. If you want to upgrade to 6.35 OFW, follow this guide.

At this point you have three choices to choose from:

Tags: ,

Comments ( 2 )

Have Something To Say ?

  1. Kenshin March 5, 2012 Reply

    Pwede ba 6.35 Pro-B10?

Leave a Reply

website stats