Atma Xplorer

Xploring Games, Computing, Photography

Prometheus-3 for 5.00 M33, 5.03 GEN-C and 5.50 GEN-D3

For those looking to play the latest PSP games that require 6.31 OFW on your favorite custom firmware but can’t due to the new firmware requirement, Chinese hacker liquidzigong has updated his Prometheus module

website stats