Atma Xplorer

Xploring Games, Computing, Photography

HowTo: Upgrade your PSP to 6.38 OFW

On an earlier post regarding the release of 6.38 OFW for the PSP, my advise was to not upgrade to 6.38 because it patches exploits used to run Hen and other fun things on

[Guide] Downgrade your PSP to any 6.xx OFW

If you have updated your PSP to 6.38 OFW or 6.37 OFW or even the latest PSP firmware, 6.60 OFW and found yourself without a Hen or CFW that’ll allow you to run homebrew

website stats