Atma Xplorer

Xploring Games, Computing, Photography

LightVSH Menu v7 for 6.35 Hen and 6.31 Hen

PSP Homebrew developer has updated his LightVSH menu plugin with a few bugfixes and additional features.  If you’re on 6.35 Hen or 6.31 Hen, you’ll want to update to LightVSH Menu v7. Requirements: A PSP with


HowTo: Downgrade your PSP from 6.35/6.31 to 6.20

Davee (yep, the very same guy that the PSP community owes the ChickHen Hack to) has released a downgrader that will allow PSPs currently on 6.31 & 6.35 to downgrade their firmwares to 6.20.


HowTo: Upgrade your PSP to 6.31 OFW

Here are the instructions on how to upgrade your PSP to 6.35 OFW so you can install any of the following Hen to run Homebrew or ISO backups of PSP games: 6.31 Hen Signed 6.31 Hen Requirements: Download


Install Signed 6.31 Hen PRO + Prometheus ISO loader on your PSP

Oh look, 6.31 Hen now also has a signed installer allowing you to install 6.31 Hen without running the Minna no Sukkuri demo exploit as instructed in the original post. With Liquidzigong’s release


Install 6.31 Hen + Prometheus ISO loader on your PSP

PSP owners with 6.31 OFW can now have cfw installed courtesy of the 6.31 Hen, 6.31 hbl by wololo and the Prometheus ISO loader.  Note that if you’re on 6.20 OFW, follow this guide


Davee’s 09g Downgrader

While some1’s current release of his 6.xx Downgrader works wonders, PSP owners with 08g and 09g models are left out of the option of downgrading to 6.20. Thanks Sony. PSP Dev Davee


[Guide] Downgrade your PSP to any 6.xx OFW

If you have updated your PSP to 6.38 OFW or 6.37 OFW or even the latest PSP firmware, 6.60 OFW and found yourself without a Hen or CFW that’ll allow you to run homebrew


Create an XMB-Icon using ISO Tool

This guide will teach you how to create XMB-Icons using Taka’s ISO Tool for PSPs using any of the following firmware: 6.20 TN-C / 6.20 TN-D / 6.20 TN-E 6.31 Hen / Signed 6.31 Hen 6.35 Hen


aLoader 1.0 for 6.20 TN Hen

ardi has just released version 1.0 of his aLoader plugin for 6.20 TN HEN, an alternative ISO loader to the Prometheus ISO loader and the OpenIdea ISO loader. aLoader llows users to boot ISO’s straight


Games compatible with OpenIdea ISO loader

This is a compatibility list for PSP users using OpenIdea ISO loader. If you’re on the following firmwares 6.20 TN-A Hen, 6.20 TN-B Hen, 6.20 TN-C Hen then be sure to check out this


Install OpenIdea ISO loader on your PSP

If you’re having problems playing games with the Prometheus ISO loader, don’t fret, a challenger has appeared :). Enter the OpenIdea ISO loader. It functions just the same as the more popular


PSP for Dummies: 6.35 OFW (and below) for non-hackable PSPs

PSP for Dummies > 6.35 OFW (and below) for non-hackable PSPs You have reached this page because you want to install custom firmware on your non-hackable PSP but have firmware above 6.20. While there


Install Signed 6.20 TN-C Hen + Prometheus ISO loader on your PSP

Total_Noob has released an update to 6.20 TN-A (and TN-B) fixing bugs and pushing quite a few features that merit an update.  What’s more interesting is that 6.20 TN-C is now signed, meaning it


PSP 6.37 firmware now available – don’t update

To address the full security compromise of the PSP, Sony has issued a new firmware that aims to defeat the user mode exploits available in 6.35 Hen, 6.31 Hen and 6.20 TN-A Hen. Important: If


Install Signed 6.35 Hen PRO + Prometheus ISO loader on your PSP

Great news for PSP users running 6.35, you can now install 6.35 Hen without running the Minna no Sukkuri demo exploit as instructed in the original post.  With Liquidzigong’s release of a signed 6.35


Installing Prometheus ISO loader

This guide will help you install the Prometheus ISO loader on your PSP. You must be on the following firmware for PROMETHEUS ISO LOADER to work: 6.20 TN-A, 6.20 TN-C, 6.20 TN-D, 6.20 TN-E 6.31 Hen, Signed


Games compatible with Prometheus ISO loader

This is a compatibility list for PSP users using Prometheus ISO loader. If you’re on the following firmwares (6.20 TN-A Hen, 6.20 TN-B Hen, 6.20 TN-C Hen, 6.31 Hen, 6.35 Hen) then be


Install 6.35 Hen + Prometheus ISO loader on your PSP

If your PSP is on 6.35 OFW, don’t fret, there’s still the 6.35 Hen available for your system and the Prometheus ISO loader that will allow you to play those free PSP games.


Install 6.20 TN-A Hen and Prometheus ISO loader on your PSP

Thanks to the efforts of Wololo and Liquidzigong, PSP-3000, PSP-2000 with TA-v88v3 motherboard or PSP Go owners can now have custom firmware (well it’s pseudo-cfw.. it’s actually HBL + ISO loader but let’s call


Prometheus-3 for 5.00 M33, 5.03 GEN-C and 5.50 GEN-D3

For those looking to play the latest PSP games that require 6.31 OFW on your favorite custom firmware but can’t due to the new firmware requirement, Chinese hacker liquidzigong has updated his Prometheus module


website stats